Linda - Rode hard and abused

Joined
Aug 27, 2022
Messages
127
Location
Ste. Genevieve, MO
#68
Finished Linda today! I have one problem that I can't correct. The right meter has a static charge I can't get rid of. Took the face off and the meter works fine. Put the face on and the needle stays in one place and doesn't move. Swipe my finger across it and it goes where ever I want it to. It's not binding, with the face off I can move it past the needle and it will follow. Tried an anticling dryer sheet and it don't help. Any ideas? 20240411_162828.jpg
 

bill7621

Chief Journeyman
Joined
Jan 31, 2016
Messages
590
Location
Berlin Center, Ohio
Tagline
WTF, y'all
#72
I've always found that a zerostat like J!m suggested worked well at removing a static charge from albums and pretty much anything else that built up static charge. A lot of people claim they don't work, but I've gone through 5 of them since the 80's and they all worked great. Try the dryer sheet and wet rag as they don't cost anything though.
 
Joined
Aug 27, 2022
Messages
127
Location
Ste. Genevieve, MO
#73
Not sure what fixed it. Cleaned the gunk off thinking the residue from the capacitor might be magnetic. 20240412_095912.jpg 20240412_095353.jpg Tried the dryer sheet, popped the front cover and hand washed it with dawn. Shorted the connections and let it sit for a while. Lifted the internal negative lead away from the case...
No one thing seemed to work. Finally installed it for the last time and it started working. Gave it a test tone and matched the meters. All is good...for now.
 
Top