David's Phase Linear 700B Thread

Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
PL used strips of drafting Mylar. These are the sheets that replaced vellum for doing mechanical drawings and survey plot plans the old school way. It has a frosted surface for drawing on and a gloss surface on the back. The stuff is readily available
Thanks for providing that info Joe. I hadn’t recalled anyone here ever saying what it was. I think that’s what Don provided me. But it had a slightly more blue hue than what the PL originals had. Of course, you are also comparing 40yr old srtips to new. Since I have so many amps in the same room; it sounds like it may be more prudent to buy some of that mylar and replace them ALL. Very helpful Joe. Thank you.
 

mlucitt

Veteran and General Yakker
Joined
Jun 24, 2011
Messages
2,124
Location
Jacksonville, FL
PL used strips of drafting Mylar. These are the sheets that replaced vellum for doing mechanical drawings and survey plot plans the old school way. It has a frosted surface for drawing on and a gloss surface on the back. The stuff is readily available
I measured one of the old PL700B Mylar strips and it read 0.005" on the micrometer. I assume that is 5 mils. I see frosted sheets of 5 mil Mylar sheets (5) for $9.00. If anybody needs a sheet, let me know, I will soon have plenty.
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
Hey Mark, I still haven't received those yet? I suspect the USPS system either lost it or the whole Covid excuse thing is really affecting even something as simple as your envelope. Joe sent off a PL400 Light board to me like three weeks ago and it's still not here. USPS hates Tubes. The receiving time is always twice that of boxes and that's on a NORMAL day.. I'm almost jokingly thinking he should put them in the tube and then hide the tube in a BOX. LOL! Maybe they'd treat it differently?

BTW, on this whole Mylar Strip thing.........I WAS WRONG ABOUT BEING WRONG!!

I actually took the time the other day (now that I'm on Vacation) and tore the amp rack down and pulled apart all four of those amps. And what did I find? I did NOT in fact replace the PL700B original strips. I left them as was. So Back to Joes point about LED degradation. Why do I say that? Well I ALSO replaced all four amps light boards with new ones and what do you know? WHITE as day! The Blueish Hue was gone. Now all EIGHT amps look identical. The difference is clear in the before and after below, shot within the same hour. Un-noticeable to the guy with one amp in a rack, but obvious to ME, my Wife, My father, and my two Brothers. We all can't be that color blind.

Now this answered what did I do with the Mylar strips that Doug (Fitz43) sent me all that time ago? I believe I used them on that PL700B that Jerry got from me. I knew I had used them SOMEwhere. I just couldn't remember where. I'm a pretty detail oriented guy so when I see something off, I usually know why right away WHY. My time messing with these amps has been so far and few between as of the last 5 years, that without opening them up; I just couldn't tell you what I did to which amp. The only clear consensus in this household was the fact I replaced those light boards all at the same time 5 years ago. So now; problem solved.
IMG_E3528.JPG


IMG_E3527.JPG
 

mlucitt

Veteran and General Yakker
Joined
Jun 24, 2011
Messages
2,124
Location
Jacksonville, FL
The package of Mylar sheets was a flat manila envelope, perhaps it is wrapped around a roller at the USPS processing plant, or a driver did not want to sit on a wet seat in the delivery truck. Who knows, maybe it will show up sometime in 2021...
 

Gepetto

Administrator
Staff member
Joined
May 15, 2011
Messages
9,011
Location
Sterling, MA
Tagline
Old 'Arn Enthusiast
The package of Mylar sheets was a flat manila envelope, perhaps it is wrapped around a roller at the USPS processing plant, or a driver did not want to sit on a wet seat in the delivery truck. Who knows, maybe it will show up sometime in 2021...
Lots of mail items are just piling up at USPS and going nowhere. They are overwhelmed. I have 12 shipments in USPS limbo right now wit zero movement in over 4 days. All priority packages
 

Gibsonian

Chief Journeyman
Joined
Aug 3, 2011
Messages
526
Between removing many automated sorting machines and limiting hours beginning this summer, leading into a Covid affected Christmas season the USPS is slower then it has been in my lifetime. Delivery times are at an all time low. Won't be back to normal likely till Feb/March I would estimate.
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
Lots of mail items are just piling up at USPS and going nowhere. They are overwhelmed. I have 12 shipments in USPS limbo right now wit zero movement in over 4 days. All priority packages
I can’t even say it’s limited to USPS. I ordered that ON-OFF-ON switch from Mouser for Joes new Rev C PL400 light board on Dec 8th with 2-Day Fed ex shipping (because it cost the same as snailmail), and it got stuck in some Fed-Ex hub on the 10th. That was the last update I got from tracking. My guess it’s lost. I had to re-order. Also did the same for a batch of new bias transistors. 2-day. But honestly given the current state of affairs, I don’t expect to receive anything until some time in 2021. If I DO; well call me pleasantly surprised. I get daily USPS mail emails. And they are giving the same message every day along with pictures of my mail. (or the neighbors mail lately or mine missing all together). This was concerning since a picture of my personal property tax mail piece that was taken a week ago, never showed up. Not that I mind that....but there’s some “thing” about the gov’t commin to get you if you don’t pay your taxes? ......I just paid it online. But it’s the first time I have ever had that. The news says they are in “CODE RED” right now at USPS. Agreed. I wouldn’t want to be a postal worker right now either. Yikes......

36FA488A-DFD2-498C-8EC7-4F84CE975BA4.jpeg
 

Gepetto

Administrator
Staff member
Joined
May 15, 2011
Messages
9,011
Location
Sterling, MA
Tagline
Old 'Arn Enthusiast
I can’t even say it’s limited to USPS. I ordered that ON-OFF-ON switch from Mouser for Joes new Rev C PL400 light board on Dec 8th with 2-Day Fed ex shipping (because it cost the same as snailmail), and it got stuck in some Fed-Ex hub on the 10th. That was the last update I got from tracking. My guess it’s lost. I had to re-order. Also did the same for a batch of new bias transistors. 2-day. But honestly given the current state of affairs, I don’t expect to receive anything until some time in 2021. If I DO; well call me pleasantly surprised. I get daily USPS mail emails. And they are giving the same message every day along with pictures of my mail. (or the neighbors mail lately or mine missing all together). This was concerning since a picture of my personal property tax mail piece that was taken a week ago, never showed up. Not that I mind that....but there’s some “thing” about the gov’t commin to get you if you don’t pay your taxes? ......I just paid it online. But it’s the first time I have ever had that. The news says they are in “CODE RED” right now at USPS. Agreed. I wouldn’t want to be a postal worker right now either. Yikes......

View attachment 46724
The bias transistors are in the backplane kit you purchased David...
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
Depending on how well this project goes; It was a good idea to purchase the transistors. I may end up not doing backplanes on a future build and go Quasi and well....let’s face it. At 23 cents a piece, I really didn’t feel too poor for ordering ten of them. (The next price reduction was at qty 100). Everyone else around here seems to talk of having 100 of everything cept me soooo.... guess I better start keeping up with the Jonses......
 

Gepetto

Administrator
Staff member
Joined
May 15, 2011
Messages
9,011
Location
Sterling, MA
Tagline
Old 'Arn Enthusiast
Depending on how well this project goes; It was a good idea to purchase the transistors. I may end up not doing backplanes on a future build and go Quasi and well....let’s face it. At 23 cents a piece, I really didn’t feel too poor for ordering ten of them. (The next price reduction was at qty 100). Everyone else around here seems to talk of having 100 of everything cept me soooo.... guess I better start keeping up with the Jonses......
Once you hear full comp David, I don't think you will go back...
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
The package of Mylar sheets was a flat manila envelope, perhaps it is wrapped around a roller at the USPS processing plant, or a driver did not want to sit on a wet seat in the delivery truck. Who knows, maybe it will show up sometime in 2021...
Mark; I literally received them on Saturday. So you were CLOSE! Thanks for sending them!
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
Once you hear full comp David, I don't think you will go back...
Thanks Joe!

I am already half-way into the project. I have had a hard time getting on here through an actual computer. My Home PC Tower decided to take a Dump on me two weeks ago and the company laptop I use ONLY for running AutoCAD Electrical 2021. I don't surf with it, but right now....I have no choice. I'm hoping to get through this project without blowing something up; but knowing me, I doubt it. I will continue the topic of this build in the appropriate thread.

:dark1::sign6::offtheair:
 
Joined
May 26, 2013
Messages
636
Location
St. Louis, MO.
Tagline
Born and Raised In The 700 Watt Club.
Thanks for all your help guys on the WOPL400 Build for my father. I learned SO much from doing it myself. And of course put it out there to be critiqued. I take all the good and bad. I wanted it to be successful and was very glad to hear that everyone liked how it went.

I can turn my attention BACK to my own system. I myself do not own ANY PL400's. Nor will I. It's ALL PL700B's. And with that obviously comes more power, more cost, and more technicals when White Oaking one. The day will come for that; but not before I have completed my speaker build. One thing at a time. So this year at some point soon I will embark on building more pairs. It's been a very long time since I built the last sets. We are talking before cell phones had cameras in them and 35mm film was still par for the course. Therefore, I do not have a lot of pictures of that build. What I DO have is in my photo archive if you dig back far enough, you'll see the whole set. I captured one scan of it below.

This is what I have planned for THIS year. One set at a time as my free time allows. (Which I hardly have). On paper, I have what I want the system to be for the next couple years. And then I go after the other stack. Right now I have TWO Electronic crossovers. One for each stack. (I do not show that here), but it's wired up. This way the meters all bounce the same on both channels on both stacks. It's prepared for the Phase 2 Build.

Phase 1 will be what I want to accomplish this year. After all; what good are amps you can't use?..................

Speaker System Design Layout.PNG

Sample.PNG
005.jpg
 
Top