Russ' PL 3300 Ser II

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#1
In for the cap and op-amp treatment... won't be dismounting these pots, someone has already put rivets in the holes...
 

Attachments

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#3
To do the 10uf PP in place of the 4.7uf axials in C106, C206 I bent the polypro leads to the side, then soldered a resistor in place of the cap and cut the resistor out leaving 2 soldered in place leads, then set the 10uf poly pro on the board and soldered it in. Less trouble than trying to extend the leads on the poly then bending them to fit.
 

Attachments

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#6
Joe we'll soon know in awhile on the AP, but the low freq response on this pre now is real close to the Spec 1.
 

NavLinear

Veteran and General Yakker
Joined
Apr 12, 2012
Messages
5,689
Location
SoCal
Tagline
Survived the Thomas fire
#8
Must be talkin to myself again, damn, I gotta quit that.....
This was a quickie.

Did you replace the tantalum capacitors on the output stage?

So how did the pot cleaning go with the switches left on the board? It would make the upgrade alot easier without removing those before cleaning. I've gone to using a cut up rag to stuff around anything I'm using DeOxit on to keep the over spray to a minimum. I recently did a turntable and it seemed to work out well.

By the way - nice job. Ok - now you can talk to yourself again. :happy7:
 

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#9
Thanks Nav. No, "Gang-O-Caps" this time. Been backordered for months. had 2 left over from Ken's. That's what was used for C106,206. Once I got the right bend on the D-100 tube it went great.
 

NavLinear

Veteran and General Yakker
Joined
Apr 12, 2012
Messages
5,689
Location
SoCal
Tagline
Survived the Thomas fire
#14
Cool - have you ever done a before modification test on one of these. I don't remember seeing one - but that doesn't mean anything. :rabbit:

I have a big list of components that I want to buy and those caps you used on the output are on my list and they were out of stock the minute I looked. You must've bought them the last of them. These thru-hole components are getting harder to come by - we'll need to come up with a method to use surface mount replacement components in the future. :shock:
 

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#15
yep, I was hoping you'd notice that,, I've tested Ken's. Maybe I didnt post ir...
 

laatsch55

Administrator,
Staff member
Joined
Jan 14, 2011
Messages
59,158
Location
Gillette, Wyo.
Tagline
Halfbiass...Electron Herder and Backass Woof
#20
I actually have some time today...no paperwork, done pumping, DAYAM!! I might get to like this.

Russ' 3300 Ser II came back for intermittent operation and noise in the phono section.....
 

Attachments

Top