700 DCP, no delay at power up,

WOPL Sniffer

Veteran and General Yakker
Joined
Aug 10, 2015
Messages
4,263
Location
Arizona
Tagline
Screw it
#1
Lee (or anybody in the know) I don't have a schematic for the 700 DCP. what components control the delay at power up? I have a DCP sitting here and as soon as you hit the power button, the relays click immediately so you hear noise (thump) at power up. I have another one sitting here and it has the normal 1-2 second delay during power up so you don't HEAR the amp circuitry coming up to speed. Looking at the components, I don't see anything different (although I did have to change a bad 2n6517, Q2 which was dead). It didn't help. It still clicks immediately.
 

jbeckva

Admin/Server Dude
Staff member
Joined
Jun 11, 2010
Messages
6,553
Location
Powhatan, Virginia, United States
Tagline
Errm... Ey Vatos!!!!
#2
Lee (or anybody in the know) I don't have a schematic for the 700 DCP. what components control the delay at power up? I have a DCP sitting here and as soon as you hit the power button, the relays click immediately so you hear noise (thump) at power up. I have another one sitting here and it has the normal 1-2 second delay during power up so you don't HEAR the amp circuitry coming up to speed. Looking at the components, I don't see anything different (although I did have to change a bad 2n6517, Q2 which was dead). It didn't help. It still clicks immediately.
C2 Upon power up it should be shutting off Q2 until it charges up, which conversely drives Q3 which is the relay drive tranny itself.
 

oldphaser

Chief Journeyman
Joined
Sep 8, 2012
Messages
720
#8
Last edited:
Top